Missile Launch Prevention Team In Place
Incident Report for US Government
Resolved
This incident has been resolved.
Posted about 4 years ago. Oct 01, 2013 - 15:21 UTC
Update
UPDATE: When we say "call us", we obviously meant "leave a voicemail". Our phone system is on fire. And I do mean "on fire". There are flames coming from the PBX system.
Posted about 4 years ago. Oct 01, 2013 - 14:54 UTC
Monitoring
We want you to know that we have found an excellent team to re-staff the Missile Launch Prevention System. We have recruited them using our connections with Walmart. We have full confidence that we will not erroneously launch any missiles.

However, if you see any missiles in the sky, please call us.
Posted about 4 years ago. Oct 01, 2013 - 14:34 UTC