US Government to File for IPO
Incident Report for US Government
Resolved
This incident has been resolved.
Posted over 3 years ago. Oct 04, 2013 - 15:09 UTC
Identified
Rosa Gumataotao Rios, Treasurer of the United States, has announced that the Government of Chevron Presents The United States of America, In Association with Coca-Cola is going to file for an IPO on the NASDAQ in order to raise funds.

"We have been in discussion with Dick Costolo, CEO of Twitter, since the government shutdown and are confident that listing on the NASDAQ is the way to go" said Rios. "Mr. Costolo has been an invaluable advisor to us in this trying time even though talking in sentences of 140 characters or less is exhausting".

Expect the stock to begin trading in approximately 30 minutes, under the symbol HOG. "We are aware of the pork barrel implications of the symbol HOG but we had to choose between HOG and CON and selected the least offensive one" said Rios.
Posted over 3 years ago. Oct 04, 2013 - 12:31 UTC