Attention Residents of Roswell, New Mexico
Incident Report for US Government
Resolved
This incident has been resolved.
Posted over 3 years ago. Oct 01, 2013 - 17:26 UTC
Investigating
Residents of Roswell, NM: Please do not be alarmed, this is just a drill. However, we are suggesting that you all leave the area immediately. Please get in your car and drive. Right now. There is nothing to fear.
Posted over 3 years ago. Oct 01, 2013 - 15:53 UTC