Pluto: we don't care
Incident Report for US Government
Resolved
This incident has been resolved.
Posted almost 4 years ago. Oct 01, 2013 - 15:53 UTC
Investigating
People, feel free to regard Pluto as a planet if you wish. Please stop calling us about it, we have other fish to fry. And I mean that literally. There are twenty Five Star Generals on the lawn outside the White House frying fish trying to feed the thinktank at work in the building since the White House Kitchen was unfunded.
Posted almost 4 years ago. Oct 01, 2013 - 15:45 UTC