Can You Assist at Three Mile Island?
Incident Report for US Government
Resolved
Three Mile Island is stable now. The noises you hear and any odd shaped clouds you might notice in the area are natural events. Earthquakes, etc.
Posted over 3 years ago. Oct 01, 2013 - 20:17 UTC
Investigating
Due to a few unfortunate budget cuts we need some help at Three Mile Island Nuclear Station near the town formerly known as Middletown, PA. If you are an extremely fast runner, have only a few days to live (bring a doctor's note), or are a responsible citizen with a laissez-faire outlook then please report to the Incident Command Center near the smaller crater in the southern part of area. Bring a change of clothes. Fully catered.
Posted over 3 years ago. Oct 01, 2013 - 19:20 UTC