Free (small) ice cream at Cold Stone Creamery for non essential workers
Incident Report for US Government
Resolved
Promotion has ended early.
Posted about 4 years ago. Oct 01, 2013 - 20:47 UTC
Identified
Kevin Blackwell, CEO of Cold Stone Creamery, and also newly appointed US Ambassador to Turks and Caicos (effective immediately) has announced that all 800,000 furloughed "non essential" government employees can present themselves at any of the 1,100 Cold Stone Creamery locations for a free (small) ice cream (sprinkles extra). You will simply need to produce a government ID and prove your non-essentialness in a series of challenges, in order to take part in the promotion.

"This should put a smile on the faces of the almost 1 million employees whom our government doesn't really need at all" Mr Blackwell said, aboard his Air Force Gulfstream V headed to the Caribbean.
Posted about 4 years ago. Oct 01, 2013 - 20:28 UTC